JavaScript

node.js

Lionの下準備

  1. xcodeのinstall
    appstoreから
  2. macportsのinstall
    http://www.macports.org/install.php

node.js

dekuyou-no-MacBook-Air:~ dekuyou$ sudo port selfupdate
Warning: xcodebuild exists but failed to execute
--->  Updating MacPorts base sources using rsync
MacPorts base version 2.0.4 installed,
MacPorts base version 2.0.4 downloaded.
--->  Updating the ports tree
--->  MacPorts base is already the latest version

The ports tree has been updated. To upgrade your installed ports, you should run
  port upgrade outdated

あれ?

dekuyou-no-MacBook-Air:~ dekuyou$ sudo port install nodejs
Password:
Warning: xcodebuild exists but failed to execute
Warning: Xcode appears to be installed but xcodebuild is unusable; some ports will likely fail to build.
Warning: You may need to run `sudo xcode-select -switch /Applications/Xcode.app`
Warning: The Command Line Tools for Xcode don't appear to be installed; most ports will likely fail to build.
Warning: See http://guide.macports.org/chunked/installing.xcode.html for more information.
--->  Computing dependencies for nodejsError: Unable to execute port: can't read "build.cmd": Failed to locate 'make' in path: '/opt/local/bin:/opt/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin' or at its MacPorts configuration time location, did you move it?
To report a bug, see <http://guide.macports.org/#project.tickets>

https://developer.apple.com/downloads/index.action?name=for%20Xcode%20-#

から、Command Line Tools for Xcode を入れる

dekuyou-no-MacBook-Air:~ dekuyou$ sudo port install nodejs
Password:
Warning: xcodebuild exists but failed to execute
Warning: Xcode appears to be installed but xcodebuild is unusable; some ports will likely fail to build.
Warning: You may need to run `sudo xcode-select -switch /Applications/Xcode.app`
--->  Computing dependencies for nodejs
--->  Dependencies to be installed: openssl zlib pkgconfig glib2 gettext expat libiconv gperf ncurses ncursesw libffi perl5 perl5.12 gdbm xz python27 bzip2 db46 libedit python_select sqlite3
--->  Fetching archive for zlib
--->  Attempting to fetch zlib-1.2.6_0.darwin_11.x86_64.tbz2 from http://packages.macports.org/zlib
--->  Fetching zlib
--->  Attempting to fetch zlib-1.2.6.tar.bz2 from http://distfiles.macports.org/zlib
--->  Verifying checksum(s) for zlib
--->  Extracting zlib
Error: Couldn't determine your Xcode version (from '/usr/bin/xcodebuild -version').
Error: 
Error: If you have not installed Xcode, install it now; see:
Error: http://guide.macports.org/chunked/installing.xcode.html
Error: 
Error: Target org.macports.extract returned: unable to find Xcode
Error: Failed to install zlib
Log for zlib is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_archivers_zlib/zlib/main.log
Error: The following dependencies were not installed: openssl zlib pkgconfig glib2 gettext expat libiconv gperf ncurses ncursesw libffi perl5 perl5.12 gdbm xz python27 bzip2 db46 libedit python_select sqlite3
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>
dekuyou-no-MacBook-Air:~ dekuyou$ 

なんでかな。。。。

dekuyou-no-MacBook-Air:~ dekuyou$ xcode-select -print-path
xcode-select: Error: No Xcode folder is set. Run xcode-select -switch <xcode_folder_path> to set the path to the Xcode folder.
dekuyou-no-MacBook-Air:~ dekuyou$ 

Path通った。。。

dekuyou-no-MacBook-Air:~ dekuyou$ sudo port installed
No ports are installed.
dekuyou-no-MacBook-Air:~ dekuyou$ xcode-select -print-path/Applications/Xcode.app/Contents/Developer
dekuyou-no-MacBook-Air:~ dekuyou$ 

eclipse

Eclipse IDE for JavaScript Web Developers | Eclipse Packages

plug-in

heroku

node.js websocket が利用できる? http://www.heroku.com/


トップ   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS